Official doc is wrong? I got a certificate working for a sub-domain automatically

Site name:

TLDR: I did the contrary of the documentation and it worked better

  1. I use Google Domains to manage the DNS
  2. Yet there was a netlify DNS ZONE active (this probably enabled the “hack”)
  3. I activated Branch deploy for branch en
  4. I activated the feature for the subdomain en (english) to match the branch in netlify DNS
  5. I renewed the CERTIFICATE , it generated a certificate for automatically
    Screenshot 2022-07-23 at 23.26.17
  6. Then I deleted the netlify DNS zone as recommended when handling DNS outside
  7. Yet everything still somehow works?

I’m totally confused because I made the contrary of what is prescribed here [Support Guide] How to use Netlify’s branch deploy feature without Netlify DNS and yet everything works and arguably even better as I didnt have to manually ask for a certificate!

  1. My CNAME record does not follow the en.www recommendation, but the doc says it is required, and yet it works…

Hi @toinewx,

I believe the behaviour has changed in the recent times. We’re trying to get this confirmed with the devs. If it has, we’ll update the documentation.

1 Like

Hey @toinewx,

The engineers confirmed that the behaviour has not changed and your hack worked because of the DNS Zone.

1 Like