Automatic SSL not working for branche subdomain (Netlify DNS enabled)

I’m using Netlify DNS and have a branche subdomain ( It received a * certificate which is invalid. Tried redeploying and renewing but no luck. Anything I’m missing on my end?

Hi, @johanbaaij, and welcome to the Netlify community site. :slightly_smiling_face:

I’ve noticed there are two domain names being managed by Netlify DNS but not showing Netlify DNS enabled for them here.

My suggestion would be to remove these two domains (the two missing “Netlify DNS”) and then add them back as domain aliases again. Once that is done, all three domains should show “Netlify DNS” like the screenshot below:


Next, if all three domains show “Netlify DNS”, then click the button “Renew certificate” here.

Note, you will need to wait about 2 minutes before refreshing the page manually to see if the certificate renewal succeeded or not.

If the certificate doesn’t update to add the new branch subdomain or if “Netlify DNS” doesn’t appear for the other two domain names, please reply here to let us know.

That did the trick, thank you for the clear instructions!

1 Like

@luke, seems the issue is back. The list of HTTPS domains changed from

*, *,
to *,

Not entirely sure what caused it, I believe it happened after I did a branche deploy.

Hi, @johanbaaij, I’m showing the SSL certificate us back to: *, *,

Is the issue resolved now?

What I ended up doing was changing from to so it would pick the * certificate. I do see * back in the list but will probably stick with my current setup for now.

If I run into this issue again with other projects I’ll create another topic. Thanks for all your help!