Nothing happens when I click the Submit button

Hello, I have some problems with the form submission. I didn’t have it before when I was using the Netlify-based page, I noticed it only when I deploy it on my own domain. Here’s my website and here’s also my Netlify website

I read the guide about Netlify form troubleshooting and checked my code - everything looks correct, however, when I click the submit button - nothing happens. I’m new in programming and I honestly don’t know what is the problem. Here’s a code of my form:


I would be grateful if you can help me.
Thank you!

Hi @discoredance :wave:t2:

That was me that just submitted your form, FYI :slight_smile:

Yeah, this is odd. Is this a controlled form in one way or another? Do you have a javascript function running to handle that form’s submit action? (e.g. submit handler)

I submitted your form by changing the <button type="input">xyz</button> to an <input type="submit"> but that shouldn’t actually be required… my own site’s contact form button is a <button> too. Curious if some nefarious JS is running.


Hey @jonsully :slight_smile:
Thank you for your answer.

I received your submission! I don’t have any JS for the submit action. I have JS only for smooth scrolling, typewriter and navigation bar and Google Analytics snippet. The thing is it was working like a charm before I deployed it on my own domain and added Google Analytics code. That’s why I’m confused and don’t really understand what is wrong. Probably the code is okay if it worked before on the Netlify domain. Let me try to change <input type="submit">. I didn’t try it yet.

1 Like

Definitely seems a little odd to me. I truly don’t think the domain stuff is an issue - that shouldn’t impact the page content or browser parsing at all - if the button<->input swap doesn’t quite work, I’d be curious to see what would happen if you remove the analytics code you mentioned. Let me know how it’s going for you and I can take another look :grin:


Hey Jon!
I tried to change Submit to <input type=“submit” value="Submit> and it didn’t actually work for me. I don’t know why. I also completely deleted Google Analytics code and it also didn’t work. I tried on Google Chrome, Safari and Brave, without adblockers and in the incognito mode. I probably read all the troubleshooting guides and forum questions with answers on Netlify, but nothing seems to help :frowning:

Hey there :wave:t2:

So I played with your site more and found that the reason the button isn’t working is indeed javascript; just maybe not the most apparent. Your button does actually have a handler for its ‘click’ event. I’m not a jQuery wiz so I can’t elaborate much more than the below, but when I uncheck the ‘enabled’ field to unbind that button from jQuery manually, it works great.


Check that out and let me know what you find!



Hey @jonsully !

Thank you so much! It worked :slight_smile: Looks like my smooth-scrolling JS included .btn class in it. That’s why instead of opening the thank you page it tried to scroll it. But there was nothing to scroll. Thanks for your help again! Really appreciate it :slight_smile:

  • Mykhailo