Form will not submit - button type="button"

Okay so my website is at: However when I try to fill out the contact form and I hit submit like nothing happens. I have even checked the console log like when I right click and do inspect element. I honestly do not understand why this would occur. I have looked at the tips on the "debugging your forum and I’m pretty sure I followed them. Anyway here is my form code:

my form name is:“contactform”

<form class="container " method="POST" data-netlify="true" name="contactform" enctype="application/x-www-form-urlencoded">
  <div class="form-group">
    <label for="name">Name</label>
    <input class="form-control form-control-lg" name="name" type="text" id="name-input" placeholder="Enter Name" required>

  <div class="form-group">
    <label for="email">Email address</label>
    <input class="form-control form-control-lg" name="email" type="email" id="email-input" placeholder="Enter Email" required>
  <div class="form-group">
    <label for="message">Message</label>
    <textarea class="form-control message" id="description-input" name="message" rows="5" placeholder="Write your message..."></textarea>

  <button class="btn btn-primary btn-block submit" type="button" value="Send Message"> Send Message </button>

Well I’m pretty lost at this point so any help would be greatly appreciated. Also my website does show up on the forms console for Netlify.

hi @DMC09 - glad you found us.

do me a favour and try changing your button type to “submit” from “button” like in this example:

If that fixes things please let us know - if not, please provide some additional information:

some questions:

  • are you buildng your site in html or with a SSG / framework of some kind? If yes, which?
  • what is your netlify instance name?

Holy crap that worked. Thank you good sir.

Glad it worked! thanks for letting us know :slight_smile: