Non-www to www redirect not working does not work when is set as the primary domain. Both work when I set as the primary domain, but I do believe it should work both ways and I’d prefer to have www the primary.

hi jordan, did you see this blog post already? it contains a ton of information about www vs non www domains.

Yes, I have, that’s why I’m here. I’d like to use www as my primary, as I do with all my other sites on Netlify, but when I do for this domain the redirect for non-www to www does not work as it does on others, so when I end up linking people my site shorthand it errors out and I look a little silly.

The DNS and everything all looks to be setup just as my other sites, nothing that sticks out, and this well beyond propagation issues as well.

It certain appears to be set up correctly. Have you tried deleting your custom domain and re-adding it?

Yes, I have tried that.

I would really appreciate some support person looking into my account seeing how you force people here to fix problems for free accounts yet it seems to not be an issue on my end.

This has been like this for like a year now.

Hi @jordonbaade! Welcome to netlify community.

I’ve tested your site in Safari, Chrome, and Firefox on a MacBook, as well as Safari and Chrome on an iPhone. Your site loads successfully for me on all, no matter if I type in or It works either way.

You currently have the www as your primary domain, which is your stated preference.

I am happy to keep testing. Is there any other info you can provide to me so I can replicate the error you are seeing?

Hey @laura, I don’t know who did what but someone did something to fix this on Netlify’s end, it’s working just fine for me now. I only tried swapping the primary domain settings, which was an action I took the first time I tried fixing this months ago, and it reliably would result in a bad response with www set as primary, so this definitely wasn’t some short glitch, misconfiguration, or DNS propagation issue.

Everything is working great now though, but would be a lot cooler if whoever did what they did made note of it here instead of just ghost fixing it. Either way, thanks!

Hi, @jordonbaade, I was also curious what was done to resolve this and I checked the logs for what was changed.

Interestingly, there were read-only queries done by both @jen and @laura but no one made any changes. There was no ghost fixing on our part.

Also we were not able to reproduce the issue in our testing. The root domain was a 301 redirect to www and www was a 200 status.

If you see the issue again, it would help us to know more about what isn’t working. Are you getting a 404 response? Is it a DNS lookup failure?

If you do get a 404, we need to be able to find the HTTP response which returned the 404. The simplest way to do this is to send us the x-nf-request-id header which we send with every HTTP response.

There more information about this header here:

If that header isn’t available for any reason, please send the information it replaces (or as many of these details as possible). Those details are:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

Similarly, if the issue is a DNS lookup failure, we’d be happy to troubleshoot. If there is a DNS lookup failure, please let us know what domain name isn’t being found.

To summarize, we didn’t change anything on our side and both domain names alway worked when we tested. If see this issue again or if there are other questions, please let us know.

Oh okay Luke, I guess I was just lying

It could have been an error at Netlify but we don’t know without more information to troubleshoot. I’m just clarifying that no one on the support team (or anyone else as everything gets logged) made any changes so that isn’t the source of the resolution.

We’re happy to troubleshoot but we do need more data to do so.