No longer able to deploy from my Github repo

My Hugo site was working fine until recently, and suddenly stopped deploying from Github. Per the log output below, it looks like a permissions issue. I tried unlinking and re-linking my repository to make sure it is authorized. No luck.

Site name:

Build log:

9:14:52 PM: build-image version: 5b0ab77c5e46895703390c45e86a907d4b78547b (focal)

9:14:52 PM: buildbot version: 5b0ab77c5e46895703390c45e86a907d4b78547b

9:14:52 PM: Building without cache

9:14:52 PM: Starting to prepare the repo for build

9:14:53 PM: Failing build: Failed to prepare repo

9:14:53 PM: Failed during stage 'preparing repo': error checking for ref: : remote: Internal Server Error.
fatal: unable to access '': The requested URL returned error: 500
: exit status 128

9:14:54 PM: Finished processing build request in 1.328s

Build settings screenshot:

I retried the deploy a bunch more times, and suddenly it worked again. So please ignore.

Hey @digitalhobbit, glad to hear it. We were seeing errors from Github recently, but it looks like they are up and running now.