Netlify CMS updates Github but Deploy fails because it cannot read repo

I need advice to debug deploy

12:36:15 PM: Build ready to start

12:36:17 PM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d

12:36:17 PM: build-image tag: v3.3.20

12:36:17 PM: buildbot version: 78b5536ab4f742c26705d3e953381b9cde6e22ef

12:36:18 PM: Fetching cached dependencies

12:36:18 PM: Starting to download cache of 254.7KB

12:36:18 PM: Finished downloading cache in 93.583416ms

12:36:18 PM: Starting to extract cache

12:36:18 PM: Failed to fetch cache, continuing with build

12:36:18 PM: Starting to prepare the repo for build

12:36:18 PM: User git error while checking for ref refs/heads/master

12:36:18 PM: Failing build: Failed to prepare repo

12:36:18 PM: Failed during stage ‘preparing repo’: error checking for ref: Warning: Permanently added ‘’ (RSA) to the list of known hosts.
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
: exit status 128

12:36:18 PM: Finished processing build request in 772.762455ms

Any clues on this one, your CMS successfully updated my Github but the deploy says it cannot access the repository?

hmm, interesting.

If I were troubleshooting this, I would probably start by revoking access to the repo (through logging in to github and removing it) and then re-authorizing it again to see if that helps. If not, please let us know and we’ll dig a little bit deeper.

Thanks Perry, I revoked it and reauthorised it through Netlify, as a previous topic suggested but still no joy, do you think it will make a difference doing it through Github?

Thanks again Perry, I seemed to have fixed it after a few mishaps, I seemed to have deleted the Stackbit app instead of revoking permissions but managed to reinstall it through the Netlify dashboard.


1 Like