Error deploying private repo from Github


I’m trying to deploy my Hugo page that is located in a private repository on Github. The repository has a public submodule inside of it. Based on all the guides and posts I’ve read, it should “just work” if I select my repository after giving Netlify permissions to my repo through the dialogs in steps 1 and 2 of deployment. This is not the case though :frowning: . Instead, I get the a 128 status code error.

Here is the deployment log:

5:14:13 PM: build-image version: 30f629161c0736b1a3ecd8b418e5eeffab5c0faf
5:14:13 PM: build-image tag: v3.3.14
5:14:13 PM: buildbot version: 80440c4491d323247b9d55f7bea2ea6bc96ce8d2
5:14:13 PM: Fetching cached dependencies
5:14:13 PM: Failed to fetch cache, continuing with build
5:14:13 PM: Starting to prepare the repo for build
5:14:14 PM: User git error while checking for ref refs/heads/master
5:14:14 PM: Failing build: Failed to prepare repo
5:14:14 PM: Failed during stage 'preparing repo': error checking for ref: remote: Repository not found.
fatal: repository '[PRIVATE_REPO]/' not found
: exit status 128
5:14:14 PM: Finished processing build request in 1.502080386s

I’ve tried deploying by making my repo public and everything seems to deploy fine, but Netlify’s deployment environment can’t seem to find my repo if it is private. Am I missing something in my configurations? Do I need to do anything special?

Thanks in advance!

hey geoffrey, will you try logging in to github, revoking the auth for netlify for this repo, and then re-authing? that might fix it.

I’ve already tried that, but I’ll try it again.

EDIT: It seems to have worked! Thank you so much! I wonder if it had to do with Github having issues around 4pm when I was working on it (resulting in bad authentication).