No gatsby cache

I’m using gatsby-starter-netlify-cms and I have installed the Essential Gatsby v3 plugin to my website.

After successful builds (2870 new files uploaded. 100 generated pages and 2770 assets changed.), the plugins says that a cache has been updated (Essential Gatsby Build Plugin ran successfully. Stored the Gatsby cache to speed up future builds. :fire:).

However, after making a very small change (like a typo in a .md), the whole website is being rebuilt rather than this specific page.

I can see in the logs of the followings builds: “@netlify/plugin-gatsby (onPreBuild event): No Gatsby cache found. Building fresh.”

I have tried to make a fresh build without any kind of cache and then tried again but the issue is still the same.

I have this issue with Gatsby v3, but also after upgrading everything to v4.

The first deploy id: 62810aca5aa37a3fc551bf2c
An other one where the cache should have been used: 6281133445d84300088c4213
A last one where the cache is still not being found: 62811b7f6c39100009eb24c0
Website name: goofy-kare-98e46a

Note that the node_modules seems to also not be cached.

The logs also mentions that the cache could not be saved:

5:23:18 PM: Finished saving node modules
5:23:18 PM: Finished saving build plugins
5:23:18 PM: Started saving yarn cache
5:23:33 PM: Site is live :sparkles:
5:24:10 PM: Build script success
5:34:22 PM: Failed to save cache, continuing with build
5:34:22 PM: Finished processing build request in 43m51.663754417s

but does not say why.

Hey @thibautsabot,

We already have an open issue for this as it seems that a few more people are seeing this. The engineers are investigating it and we’ll let you know once we have more informatiom.