Netlify release redirects to 404

PLEASE help us help you by writing a good post!

I receive 404 when I try open main page

Build works well

It actually works before, looks like runtime upgrade changed something, btw in packagae.json I use
@netlify/plugin-nextjs”: “5.0.0-rc.3”,
“react”: “^18.2.0”,
“next”: “^14.1.3”,

node is 18

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in there, please check out this Support Guide as well. It outlines all of our build and deploy resources and will get you on the right track :slight_smile:

If none of the above resources help, please write back with your site name and what steps you have tried and we can look into this further!

Thx for answer, no luck with this for now.

I actually checked everything regarding build variables, path, etc.
Nothing changed from previous working build.
looks like some update or something I can’t catch

When I open the link you provided @nro, I see

When I copy/paste the address manually I am redirected to because release– is a Punycode address.

just fixed it before your answers)
it was internal strapi error, so thx everyone