Build is empty and site says "Page Not Found"

PLEASE help us help you by writing a good post!
My netlify site name is “” (this is what appears when redirecting from the deploy site in “”).

When I’m building the site, it says the build is successful, yet once accessing the site I get an error saying “Page Not Found Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.”.

I’ve downloaded the build from as a .zip, but it appears to be empty!
I tried following this page and changed the build directory to “build/”, but that didn’t work.

This is my common config file, and this is the production config file (which uses the common file).

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in there, please check out this Support Guide as well. It outlines all of our build and deploy resources and will get you on the right track :slight_smile:

If none of the above resources help, please write back with your project repo as well as what steps you have tried and we can look into this further! Thanks!

1 Like

I was able to solve the problem by pointing to “…/build” instead of “build”, because my config files lie in a subfolder. I wrote a comment on this post saying this but seems like it has been deleted or I didn;t have internet connection to publish it, anyway I’m sorry for the trouble and thank you for your time!