Netlify Form doesn't collect data with custom succes page/action

Hi, I have problems collecting data in my netlify-form on birgit.netlify.app when setting custom success page. When I use your default success (no action attribute), form is submitted correctly. Thanks for any advice. The page runs on svelte/vite

<form name="order" method="post" data-netlify="true" action="/success">
	<input type="hidden" name="form-name" value="order" />
	...
</form>

Hey @laydatex

The issue (or part of the issue) is https://birgit.netlify.app/success does not exist. If you wish to have a custom thanks/success/submission page, the path for that page must exist.

Sorry, I removed the page/action for testing purpouses. And yes, the form work fine with the netlify default success page. Now the custom one is deployed back and the form doesn’t submit anything as described in the topic

This is what I see after submitting the form

Hiya, sorry you are having trouble getting your forms to work.

This Support Guide is the first port of call to debug any forms issues. Please start here and work through these resources!

We also recommend trying to search the forums or look at topics tagged Netlify forms if you haven’t already - it’s likely your question was already asked by someone else!

If you are still having problems, please provide more information such as what you have already tried, your form name as it exists in the UI, and a link to your live form. :slight_smile:

The problem was in non-existing endpoint page so I’ve set a pre-render as mentioned in the support guide. Thanks.

1 Like

Thanks for coming back and letting us know! Glad everything is up and running now.