Netlify does not let me use a certain site name that I used previously

I have had a netlify site running for about a year now, but I just recently realized it was not up. When I looked at the netlify project logs and everything, there seemed to be nothing wrong, and when I changed the site name to something else, it worked.

When I open the original site name, there is nothing besides the standard “Unable to connect” error message firefox gives for an unpublished URL. I also tried to delete my project on netlify and recreate it, and still it does not work unless I change the name.

Another question I had was that, when I look it up on google, the site name appears as “Netlify,” how would i change this?

The site name used to be and now it is

Sounds like some local issue. I’m getting a site not found page.

That’s more of a SEO question than Netlify question which we can’t help effectively with.

“unable to connect” is what I get on Firefox; it’s not a message from Netlify. I assume it is equivalent to “Site not found.” on chrome

This issue is now happening when I use the name “scoped-sort” now as well.

When I use these names, it says the deployment and everything went well, but the website is not actually deployed.

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues. I checked your site and i’m getting the 404 page and in the browser console.

If you are still seeing issues after following the troubleshooting steps in there, please check out this Support Guide as well. It outlines all of our build and deploy resources and will get you on the right track :slight_smile:


I have just tried troubleshooting with both help pages, and I still am receiving this issue. To re-iterate, my builds and deployments seem to be working fine when I use different site names, but when I go to the deployed website, it won’t show up if I use previous site names.

I have also tried removing the browser’s cache, but that also does not work.

I’m not sure what you mean. There’s no site named scoped-sort, so not sure what you’re trying to say by everything went well. Where are you seeing everything went well?

So far, everything looks to be working as intended from our end. There’s no site with that name, so we’re saying site not found.

That is because I changed the name for the time being so that my site still deploys. When I change the site name to “scoped-sort” or “scopedsort” it does not display a website. It’s not netlify saying there is no website found, it’s the browser.

Where are you seeing everything went well?

In the build / deploy logs.

I have set back the site name to “scoped-sort”, and it does not work like before.

Hey there! Since you’ve made some changes while we have been troubleshooting, I want to make sure we still understand where we’re at with this issue. Let me know if I’m interpreting it correctly.

I am seeing that the scoped-sort site is functioning in my browser – are you still having issues? If you do, please send us the site without changing the name so we can see it in the state that you are having issues.


Yes, I am still having this issue. I have tried it on multiple devices and it still does not load. I have kept the site named scoped-sort.

Hi @karizma,

This is what I see when I go to

Can you clarify if you’re still having issues going to If you’re still having issues, does this only happen on a specific network? For example, works on your phone’s ISP, but not the ISP that you’re connecting from on your laptop?

Yes, this is the correct output. I have just tested it, and it seems to not work only when I use my College’s network (on multiple devices). When I use mobile data on my phone, it works fine.

So what is the error that you get from your college’s network? Is there an error page or something that you get? Can you get us a HAR file: HAR Analyzer (

Yes it only seems to occur on my college’s network. There is no error page, it just doesn’t output a page:

This seems to be the output of the HAR file:

scoped-sort.netlify.app_Archive [23-10-22 13-20-31].har (2.7 KB)

Sounds like something your college might be blocking then? Have you tried contacting them?

I will contact them and try to find a resolution. I don’t think they are manually blocking it, so I’m curious how/when it decides to block a website. Since this is not a Netlify-related issue anymore, I will close this. Thank you everyone!