Netlify DNS nameservers

Hello, my netlify site name is . I have my custom domain with namecheap and it’s, I used your DNS nameservers, now it’s been more than 5 days but my domain still won’t work, it’s the same nameservers as which works perfectly fine. How can I fix ? Thanks

Now when I try to set up Netlify DNS for it gives me the following error : (dns_api 403 - failed to update view digest: unauthorized: FQDN is used by multiple zones on the same view, or there is a child/parent zone owned by a different org).
Can someone help me ? Thanks

Hi, @Kris. The duplicate DNS zone isn’t at Netlify. It is at the DNS infrastructure provider we (and many other companies) use called

I have an explanation about how to resolve this here:

To summarize, if you know what other service created this zone, login to that service and delete it there. If you don’t know what other service did this, then create a free account at NS1 and then ask their support team to delete the DNS zone there.

Once the other zone is deleted, Netlify can create a new one. If there are any remaining questions or concerns, please let us know.

Hi Luke,
sorry for the late replay, I found a job and started working and I didn’t have time to work on my stuff unfortunately, now I’m back.

I tried, when you told me to create an account on ns1 but it didn’t let me, maybe 'cause I’m from Italy, but it wasn’t accepting my credit card, I talked with my bank and they said there was no problem on their side so I went back and tried again but got the same error.

Yesterday that I got back on it I tried and I still couldn’t create an account so I sent them an e-mail explaining what I needed and that I couldn’t create an account for the above reasons.

They replied saying that they now deleted the zone and that now it could be created on Netlify without any problems, though I went on Netlify and now when I try to set up Netlify DNS I get the following problem “A DNS zone for this domain already exists on NS1, the DNS provider backing Netlify DNS
so now I don’t know what to do, they just said that they deleted the zone.

Thanks for the help and again I’m sorry for the late reply

You can let them know it’s still not solved. As long as you’re getting this error, it’s only NS1 that can help.