Netlify dev serves up wrong project


When I try running netlify dev, wrong project is served.

  1. I completed my work on some project named trusting-hermann-458680
  2. Few days went by
  3. I started new project named ntmap (created git repo, cloned it, added to netlify via github addon, did netlify init and linked it to local version).
  4. I tried running netlify dev but it started serving trusting-hermann-458680 instead of ntmap
  5. I tried clearing ServiceWorker, but found none
  6. I tried changing port like this netlify dev --port 5001, but I still got the wrong project.

netlify -v:
netlify-cli/2.52.0 darwin-x64 node-v12.7.0

Hey @JesusCrow,

The third bullet point in this section will be applicable to you:

You’ll probably need to rerun netlify link. Can you try that and see if that helps?

It works at the moment properly.
Just as I had it before writing first post, I can confirm this has been done and I have a .netlify folder with a state.json file containing my siteID .
While waiting for your response I created another Netlify account and transfered all trusting-hermann-458680 stuff there. I have not touched ntmap since my message. I could probably assume that switching account in CLI fixed my problem?

Hey, a funky solution is a solution nonetheless!

The siteID is different for each site so you’ll need to relink or update this if you want to hop between them. Alternatively, a separate account would do the trick :face_with_hand_over_mouth:!