Cannot get netlify cli to start serve at localhost:8888

I am having problems getting certain projects to start the server at localhost:8888

  1. The Good

I have created a new directory and netlify starts the server at localhost:8888 as expected. The terninal log is

(node:313723) ExperimentalWarning: The Fetch API is an experimental feature. This feature could change at any time
(Use `node --trace-warnings ...` to show where the warning was created)
wasm streaming compile failed: TypeError: Failed to parse URL from /home/jeff/.nvm/versions/node/v18.7.0/lib/node_modules/netlify-cli/node_modules/netlify-redirector/lib/redirects.wasm
falling back to ArrayBuffer instantiation
◈ Netlify Dev ◈
◈ Ignored general context env var: LANG (defined in process)
◈ Ignored general context env var: LANGUAGE (defined in process)
◈ No app server detected. Using simple static server
◈ Unable to determine public folder to serve files from. Using current working directory
◈ Setup a netlify.toml file with a [dev] section to specify your dev server settings.
◈ See docs at: https://cli.netlify.com/netlify-dev#project-detection
◈ Running static server from "netlify-cli"
◈ Setting up local development server

────────────────────────────────────────────────────────────────
  Netlify Build                                                 
────────────────────────────────────────────────────────────────

❯ Version
  @netlify/build 27.15.5

❯ Flags
  {}

❯ Current directory
  /home/jeff/projects/netlify/netlify-cli

❯ Config file
  No config file was defined: using default values.

❯ Context
  dev

────────────────────────────────────────────────────────────────
  1. Run command for local development                          
────────────────────────────────────────────────────────────────


◈ Static server listening to 3999

(dev.command completed in 6ms)

   ┌─────────────────────────────────────────────────┐
   │                                                 │
   │   ◈ Server now ready on http://localhost:8888   │
   │                                                 │
   └─────────────────────────────────────────────────┘
  1. The Bad

In my existing project the server starts at localhost:5000 and I get a message in the terminal, waiting for framework port 5000

Here in the log

(node:313950) ExperimentalWarning: The Fetch API is an experimental feature. This feature could change at any time
(Use `node --trace-warnings ...` to show where the warning was created)
wasm streaming compile failed: TypeError: Failed to parse URL from /home/jeff/.nvm/versions/node/v18.7.0/lib/node_modules/netlify-cli/node_modules/netlify-redirector/lib/redirects.wasm
falling back to ArrayBuffer instantiation
◈ Netlify Dev ◈
◈ Ignored site settings env var: FAUNADB_SECRET_BBO_CHAT (defined in .env file)
◈ Injected .env file env var: FAUNADB_SECRET_BBO_CHAT
◈ Injected addon env var: FAUNADB_ADMIN_SECRET
◈ Injected addon env var: FAUNADB_SERVER_SECRET
◈ Injected addon env var: FAUNADB_CLIENT_SECRET
◈ Ignored general context env var: LANG (defined in process)
◈ Ignored general context env var: LANGUAGE (defined in process)
◈ Loaded function db-access.
◈ Functions server is listening on 45987
◈ Setting up local development server

────────────────────────────────────────────────────────────────
  Netlify Build                                                 
────────────────────────────────────────────────────────────────

❯ Version
  @netlify/build 27.15.5

❯ Flags
  {}

❯ Current directory
  /home/jeff/projects/bbochat

❯ Config file
  /home/jeff/projects/bbochat/netlify.toml

❯ Context
  dev

────────────────────────────────────────────────────────────────
  1. Run command for local development                          
────────────────────────────────────────────────────────────────

◈ Starting Netlify Dev with Svelte

> svelte-app@1.0.0 dev
> rollup -c -w

rollup v2.77.0
bundles src/main.js → public/build/bundle.js...
LiveReload enabled on port 35733
created public/build/bundle.js in 2.2s

> svelte-app@1.0.0 start
> sirv public --no-clear


  Your application is ready~! 🚀

  - Local:      http://localhost:5000
  - Network:    Add `--host` to expose

 LOGS 

 Waiting for framework port 5000. This can be configured using the 'targetPort' property in the netlify.toml

Can anybody help me understand what is going on?

Hi @psionman

There are several threads on the CLI GitHub repository about this issue. Have you looked through them?

Thanks

I downgraded to bode 16.16.0 and it works