Netlify dev returns "Exit received. Waiting for current operation to finish..."

When I run “netlify dev” it does not open a browser instance but it prints “Exit received. Waiting for current operation to finish…”. That also happens when I hit “Ctrl + C”, which is the command to stop the netlify dev server. I need to press “Ctrl + C” twice to exit.

What could be wrong?

The entire output is as follows:
Netlify Dev ◈
◈ No dev server detected, using simple static server

◈ Server listening to 3999
Waiting for localhost:3999.
◈ Lambda server is listening on 34567

Waiting for localhost:34567.

│ │
│ ◈ Server now ready on http://localhost:8888
│ │

Exit received. Waiting for current operation to finish…

Hi, @glorifiedmonkey, and welcome to our Netlify community site.

I’m not sure what would cause this but we’d be happy to take a closer look to find the root cause and (hopefully!) get this issue resolved. :slight_smile:

Do you have an example Git repo which reproduces this issue? Also, what system are you running netlify dev on? (For example, a Macbook using MacOS version 10.14.6 or Ubuntu Linux version 18.04, etc.)

Please don’t feel any pressure to provide a huge amount of detail. Just knowing the general OS version would help us to research this further.

If you want to send information to us privately I also made certain that private messages (PMs) are enabled for you.

Hi @luke,
Many thanks for your response.

I have two devices with the same behavior. MacBook Air (latest), MacBook Pro 15" 2017.
Both have the same software versions:
macOS: 10.15.1.
Node: v12.13.1
NPM: 6.12.1
Homebrew: 2.2.0

Netlify was installed using brew. When I type netlify-v, I get this:
netlify-cli/2.24.0 darwin-x64 node-v12.13.1

The repository I use is this:

I run “netlify dev” in the root directory of the folder (ubiqum-nysl-project), and I get the message as mentioned in my initial post.

Looking forward to your response.


I believe this may be happening because the dev server for your SSG is exiting. Are you able to run that separately? also note that the source of truth for bugs/issues for the Netlify CLi is the repo for the CLI: If you want to open an issue for a bug, then that’s where you would do so to get it in front of the devs working on it. Thanks!

Hey @futuregerald,
Thanks for taking the time to respond.
I do not have a build command set up because this isn’t a site built with a SSG. It’s basically html css js.
I just tried in another project (another repo) where there’s really just a index.html (without much content). I set up a new site on Netlify using “netlify init” and set no build command either. When I run “netlify dev”, the server starts for a second and then I right away get “zsh: terminated netlify dev”. It seems like it’s crashing (like you mention), but I just have no idea why. Isn’t netlify dev just a basic local environment to run html css js sites to test?
Maybe I’m understanding/using this wrong?

Hi @glorifiedmonkey, I was able to replicate this but the dev server still works. It seems the problem may just be the message telling you it’s waiting for the current operation to finish. Can you confirm that the dev server is still running until you actual exit it using CTRL + C?

Hey @futuregerald,
I can confirm that the server works until I hit CTRL + C twice.
It just wasn’t like that any other time I’ve used Netlify so I thought I have a misconfiguration or something.

Thanks for the update.

I’m also getting this error.

hey folks, thanks for sleuthing out what is happening here. I encourage you to file an issue on this repo: