Netify pre-render doesn't seem to work


We’re trying to start using Netify built-in pre-render feature but it doesn\t seem to work. I’ve tried to test the pages as described here and I get empty pages as if JS code never run.

I think we’ve set up the app properly (but I might be wrong of course).
We never used any pre-render service before.

The app is SPA React front-end. We use custom domain (original Netify address is

We don’t expect to get ready-to-use solution outsource, but is there any kind of best practice info we could consider? Is there any mistakes we made and that are “visible” outside?

Please let us know if we need to provide more app details.

Any update? Can we be pointed at any kind of doc / instruction?

Hi, sorry for the delay I didn’t see this. Can you specify what you mean by this?

Hi, no problem

There is a built-in pre-render feature you can turn on for the app. We turned it on, waited for a few days and then tried to test if the pages are pre-rendered, but it looks like they’re not. I’m not sure what information else I can provide, please let me know if you need to know anything specifically.

I’m getting this page:

when I use Googlebot UA, which is different from JavaScript being disabled (which gives a blank page). So it appears that prerendering is working fine for your site.

Hi, thanks for the answer

I’m afraid this is not how the pre-rendered page looks like. It seems like some of JS being running. From what I understand, pre-rendered page si not supposed to run any JS on client end and be a pure HTML.

Pre-rendering does run JavaScript. It runs the JavaScript and creates an HTML-only version of the page that doesn’t need JavaScript to display text. This is working as expected.