My site didn't get the git commi when i push to my repo

Hi there:

I encountered an issue:

I discovered today that Netlify is missing the website content I updated on a certain day (around June 24 to June 27).

I use Netlify to automatically deploy my website (a Hugo project), and it has worked well in the past.

However, I discovered today that the commits I made in the last few days were not updated on my website.

So I checked my blog repository and found that the commits were successfully pushed to it.

Then I went to the Netlify dashboard to check and found that the commit information was not retrieved, as shown in the screenshot below.

So now I am very confused, what caused this issue to occur?
How can it be fixed?
Best regards.

To start with, please share your site name or ID.

@hrishikesh okay, Thanks Reply.

my site name is:

Hi, are you still experiencing this issue? If so have you tried unlinking and relinking your github to netlify?

Hi @lemoana ,

Based on your commit history, we found only one commit between the days of June 24 and June 27:


The commit was made on June 25th, the same day that GitHub reported an incident with Actions and Pull Requests. This could likely explain why the commit on the 25th did not process. If you should see this reoccur, please let us know!

I’ve also tried doing this using netlify before, but it didn’t work.

My own solution is: recreate the part that had problems before, and submit it with git, and then on netlify, it can pull and deploy to the latest content successfully.

However, the cause of the problem has not yet been found.

Hi @audrey ,thx for replay,

Actually, I created two documents on June 24th, and both have content, but they were not updated to my website either.

The creation time of these two documents is as follows, (my time zone is located in UTC+8)

2c9f35d HEAD@{2023-06-25 22:15:42 +0800}: commit: 新增 “gateway 访问失败”部分
6c0e0c7 HEAD@{2023-06-24 11:50:11 +0800}: commit: 新增 文档“K8s-Rancher”
554c250 HEAD@{2023-06-24 11:35:57 +0800}: commit: 新增 文档“8ks-elk”

I think the incident of github may have an impact on the deployment, but also confused about the time.

Finally, I tried to recreate the documentation on on July 2,and find that netlify redeployed successfully.