Let’s Encrypt certificate automatically keeps failing

Hi I’ve been trying to renew the SSL/TLS manually for a week and it keeps failing. It couldn’t do it automatically so I tried doing it manually.

The error i get is:

SniCertificate::CertificateInvalidError: Unable to verify challenge for sourceseparationsystems.com.au

Sorry I’m really new to Netlify and amazed I got this far.

Thanks for help

Hi, @HanCreate, and welcome to our Netlify community site. It appears there is an AAAA record for the apex/root domain which doesn’t point to Netlify. Would you please try deleting that record and then click the “Renew certificate” button again?

Please wait one hour before clicking the button at the existing AAAA record has a 3600 time to live (TTL) value meaning will take that long to expire after deleted.

Hi @luke, I really appreciate you getting back to me. I’m just looking at my Zone Manager and there’s two AAAA records listed there. One with the url and the other with just www, should I delete both?

Thanks for your help, much appreciated.

Yup, you wouldn’t need either of those.

Looks well configured now and I see a new certificate in place - let me know if anything isn’t working as you expect now, please.

Thank you, I deleted one and it worked. I’ll delete the other soon as well. Thanks for all the help, its much appreciated.

1 Like

great. glad it’s working!