Kex_exchange_identification: Connection closed by remote host

I’m having problems deploying a new site from GitLab. I have several sites deploying private GitLab repos, but never seen this before.

In the log I’m getting:

Failing build: Failed to prepare repo
Failed during stage 'preparing repo': error checking for ref: kex_exchange_identification: Connection closed by remote host

fatal: Could not read from remote repository.

Please make sure you have the correct access rights

I had a look at the authorised applications in GitLab. There were two for Netlify. One from 2021-05-06 and another created today. The existing one had the scope of “api” while the new one was “read_user”. I tried revoking the “read_user” one and reconnecting the repo in Netlify. This prompted me to re-authorise GitLab, and in turn created a new Netlify application in GitLab, with “api” scope. I thought this might fix things, but am still getting the failing build. Either as described above, or just Error cloning repository.

The Netlify site name is dreck.

Hey @smth,

The latest deploy seems to have worked. Are you still having issues?

I waited a couple of hours, tried triggering a deploy, and it built fine. I don’t know what the problem or solution was, but it seems to have resolved itself.