Netlify deploy fails remote: ERROR: Git access over SSH is not allowed

netlify site name:

Experiencing issues building from gitlab repository (NOT self-hosted); I have already followed the recommended troubleshooting instructions found here ( Build troubleshooting tips | Netlify Docs)
this is not a new project and for the past year at least we were able to deploy to production and to create deploy previews without any issue. I have already re-linked the gitlab repo, removed any additional generated webhooks in the repo, created new secrets and have more-or-less exhausted any new approaches I could find in the documentation.

deploy log below:
2:09:19 PM: Build ready to start
2:09:35 PM: build-image version: fcb0c1b3ada6d25c1cb58e8bc514f5f23cc14f15 (focal)
2:09:35 PM: buildbot version: aa810d582dc14bf9392c9fc64b0002bffe04d8bd
2:09:35 PM: Fetching cached dependencies
2:09:35 PM: Failed to fetch cache, continuing with build
2:09:35 PM: Starting to prepare the repo for build
2:09:36 PM: Failed during stage “preparing repo”: For more information, visit Build troubleshooting tips | Netlify Docs Warning: Permanently added “” (ECDSA) to the list of known hosts.

remote: ========================================================================
remote: ERROR: Git access over SSH is not allowed

remote: ========================================================================
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
: exit status 128
2:09:36 PM: User git error while checking for ref refs/heads/main
2:09:36 PM: Failing build: Failed to prepare repo
2:09:36 PM: Finished processing build request in 1.122s

Hey there,

Thanks for reaching out! It sounds like some of the repository permission settings may have changed on the Gitlab end?

You mentioned that you’ve already created new secrets, but I’m wondering if you’ve followed the steps here, as they seem to be applicable to the specific error you’re hitting here.