Issue deploying a large Eleventy site

I’m in the process of converting my blog from Jekyll to Eleventy. It’s a large site (6000+ posts). Locally I run with an .eleventyignore file to ignore most of my content, but when I test, a full production build locally takes 30 seconds.

When I tried to do a build at Netlify though, I got JavaScript heap errors related to memory. I did some Googling and found this post on Gatsby’s repo ( that suggested setting an environment variable, NODE_OPTIONS, with the value --max_old_space_size=4096.

Doing this allowed my site to build - but when it went to the Upload stage, it worked for a long time (roughly ten minutes), and finally gave me this error:

failed during stage 'deploying site': Failed to execute deploy: &{0 } (*models.Error) is not supported by the TextConsumer, can be resolved by supporting TextUnmarshaler interface

So I’m at a lost, any ideas? Here’s the repo (, and I’m using this build instruction: npx eleventy --quiet

I randomly tried again, still got an error, this time before uploading:

failed during stage 'deploying site': Failed to execute deploy: Error: deploy timed out while waiting to enter states: prepared,ready
4:16:44 PM: Failing build: Failed to deploy site
4:16:44 PM: Finished processing build request in 5m56.261001863s

Hiya Raymond. That error says that the site is a bit too big to upload. I’ve tripled the timeout there; please let me know if that doesn’t help!

I’m testing now and will let you know. A few questions:

  1. Is this a setting we have access to, or must you ask support?
  2. Was it obvious that the site was too big from the log? I didn’t get that myself, but it’s definitely possible I missed that.
  3. I didn’t have this issue with the Jekyll version of my site. But it’s been up for a year or so. Can you check that version ( to see if the setting is roughly the same?

Disregard #2, it was obvious, “failed during stage ‘deploying site’: Failed to execute deploy: Error: deploy timed out while waiting to enter states: prepared,ready”

Actually - and sorry for all the replies! In my last failed build, I’m seeing a time of 5 minutes and 56 seconds. For my current site, before I moved to Jekyll 4, it was common for it to take 15 minutes or so. I guess this relates to question 3, does my current site have a “higher than normal” timeout setting?

the failure is not in building, it is in the upload after build “seeming” stuck - which is a 5 minute timeout between build-ends and upload-ends. If you have a ton of files to upload (even if they haven’t changed, so won’t need upload), if we don’t finish comparing checksums before 5 min is up, the build will be halted as it is presumed to have gone off the rails (and this timeout is the one I tripled :))

Cool - FYI your tweak worked. Thank you!

huzzah! You can ping here or in the helpdesk for future updates like that, though one of our dev teams is also working on speeding up that upload process in general, so that may help as soon as next week :wink:

@fool Hey, I’m getting the exact same error here :slightly_frowning_face:. I’m running a Gatsby site with like ~2510 pages.

If there is a temporary fix on your side, should I be worried in future? Because that number is subject to grow, like fast and big !

It’s a one-time fix that will stay in place. Let me know the site and we can apply the fix, though I am surprised to hear it is affecting you for a 2500-page site (unless you have more FILES than that - that’s the number that matters :slight_smile:)

Yes, it’s a ~2500 pages site and nothing else except default Gatsby files & a web font.

I pm’ed you the site but strangely, deploying is working fine now! :thinking:

1 Like

great. glad it’s working. if it happens again or other problems arise, please start a new thread. thanks!