Invite Link doesn't route properly

Hello,

I have just made my first site with netlify cms and gatsby and I’m struggling with the identity section. I have invited a user but when they click on the link it goes straight to the home page. I can see the auth token appear in the address bar but then it disappears. If the user logs in via google OAuth they get in fine, but there’s no way to ever set a password or anything.

Im using gatsby-plugin-netlify-identity but haven’t implemented anything in the jsx files as I don’t want a login widget on my main page. I just want the ability to log in via the admin route.

Can anyone help?

Simply change the email templates: https://docs.netlify.com/visitor-access/identity/identity-generated-emails/#email-templates

Hi @louisereid, I’m running into the same issue with my Netlify site that is based on the hugo-academic theme. Did you ever get your problem sorted out?

Did changing the email templates as @tomrutgers suggested do the trick?

Edit: I should add that I’ve been unable to setup admin access to my site via the invite link or the new account pathways. Any way I try it takes me to my site with whatever auth token in the address bar, but I am never prompted to set a password or verify my account.

Hi @ctrivedi, I’m pretty certain changing your email templates will do the trick. You can also enable the identity widget on your homepage. More info here: [Common Issue] Netlify CMS & Git Gateway - Email not confirmed

Brand new Netlify user here!

I am having this issue as well. Set up a Hugo install using the Netlify CMS guide. But the confirmation link just takes me to the website. The token doesn’t do anything or prompt me to create a password. I’ve seen several people say to change the email templates. I have two questions about that:

  1. Why doesn’t it just work how the Guide tells us it’s going to work?
  2. If I must update the email templates, where do I put those files, and how do I reference them in the Settings > Identity > Emails > “Path to template”? This is not clear. I’ve created the email templates as recommended in the article you linked to @tomrutgers, but I don’t know where to put them in my files. I’ve tried several places and paths, and nothing works.

Hi @logangreer, I actually answered your question on your post here: [Common Issue] Netlify CMS & Git Gateway - Email not confirmed. Let me know if that helps.