Images not loading on first load, only on mobile browsers

dear support

on www.delerueroppel.com, hosted by you, I observe a strange behaviour. everything works nicely on desktop. but if I navigate on any mobile browser to a subpage, images do not load. as soon as i hit refresh, they are all there? could this be a problem happing on your side? I am no expert and have tried to find out where the problem could be but am not able to further investigate, as it is only happening on actual mobile devices.

i would be very grateful for any help. thank you very much in advance, with kindest regards, patrick

All the images seem to load on my phone. Would you try a different device/browser/network?

thanks for getting back to me. i have tried on two different iphones, chrome and safari on both, through wifi and cellular. some images load, videos do as well. but some images just appear after refresh…

Do you have any specific set of images that produce this behaviour or were you able to narrow it down? It can help us look for and troubleshoot only those images rather than looking for the problem in the entire website.

unfortunately not. i could not localize a specific set. it only happens with still images, they are all implemented the same way.

but this page might be a good example. on it we have three videos, embedded and 15 images which only show up once the page is refreshed or in the cache…

https://www.delerueroppel.com/dr_lp_sesia

@patrickroppel You realize that you have two missing placeholder images and an error loading a font, right? These errors might be inducing loading delays.

oups… i knew about the missing placeholder images. but i am not aware of the font error?

and i cant see any console error popping up? i am very far from being any expert, so glad i you could let me know how you figured this out?

I opened a “web inspector” in Safari (other browsers have similar capabilities).

FWIW, I’ve always found it to be a good approach to fix the easy stuff first before adventuring on into the unknown.

thank you, i have tried to do the same thing. in safari and chrome. and do not get an error in regards to typefaces. i have now had the same problem on desktop. in safari, some images load, and others do not. i could then go into chrome, where everything loads. i made a screenshot of the source code. the first image does not load, the second does.

it is always the same images, not loading, but they are inserted exactly in the same manner. same css etc.

https://www.delerueroppel.com/dr_chloe_classics

the same two images in safari. first one not loaded, second loaded.

I’m seeing:

Failed to load resource: The certificate for this server is invalid. You might be connecting to a server that is pretending to be “p.typekit.net” which could put your confidential information at risk.

https://p.typekit.net/p.css?s=1&k=kcc6gdn&ht=tk&f=6770.6771&a=5283061&app=typekit&e=css

thank you. strange, i am not getting this, not in chrome, not in safari. another thing i have to go after. and some more gray hair…