Identity tab and Identity settings broken after trying to delete

  • App: nuntius-docs.netlify.app
  • Not using a custom domain
  • Builds are ok

Hello! :wave:t2:

Recently, I tried to use “Identity” for the above app. I was having trouble with local testing (“https://nuntius-docs.netlify.app/.netlify/identity” not being found). So, I tried to delete the “Identity” to try re-creating it and fix the issue.

But it seems that the deletion didn’t finish. When I go to the “Identity” tab, it still shows that I have identity enabled, and the user list keeps loading. I see this error in the console:

Failed to load resource: the server responded with a status of 500 () https://api.netlify.com/api/v1/sites/4d8ced76-7005-422a-9d1d-59ffc97204a9/identity/6010ecf4dc571c8cf15f8a2d/users?page=1&per_page=15&sort=created_at

Also, when I try to access the settings for Identity to try removing, I get a blank page. I see this error in the console:

TypeError: undefined is not an object (evaluating ‘e.getIn([“config”,“config”,“smtp”]).toObject’)

Hope the information is sufficient, happy to provide more info if needed.

Hey there,
How did you delete? Did you use this button: https://app.netlify.com/sites/nuntius-docs/settings/identity#delete-identity-instance?

Yes. To be precise: Settings / Identity / Delete button at the bottom of the page.

Very mysterious! I’m not seeing anything systemic on our end but this is obviously a problem for you- do I have your permission to manually delete the Identity instance that’s currently associated with your site?

Yes. Ok to delete the identity instance.

Just completed the manual deletion- can you let us know if that page is working better for you now?

Looks like it worked! I can see the default page now. I’ll recreate the identity to continue my setup. Thanks a lot Jen!

There’s a problem though. When I click on “Enable Identity” it fails with “Netlify Identity is already installed for nuntius-docs”.

Hey @jen! In case you missed the last message. I have a problem enabling Identity after the fix.

Thanks for the ping and sorry for the continued trouble- I’ll look into this with my colleague today and we’ll keep you posted as we learn more!

Hey there,
One thing to try: could you try redeploying your site? We’d like to see if that helps our system realize that the Identity instance has been deleted. While you try that, I’ve also created a ticket to work on this with a backend engineer tomorrow afternoon (but hopefully redeploying is all you need!)

I triggered a deployment manually using the following option. Sadly, it didn’t help.

Screenshot 2021-02-10 at 9.54.59 AM

Alright, we did a bit more manual intervention! Can you let us know if you’re able to set up Identity now?

:tada: Yes, I can enable now.

Woohoo! Glad to hear it :slight_smile: