Identity not using email templates

hi samuel, sorry it has taken us a bit to circle back to you.

any progress at all on this?

Has anyone found out a solution for adding template email with a gatsby site?

Hi @Built-Better, I think your question might be worth creating a new topic for so you can provide more context and details on what you’ve tried.

Hello

I have a problem with this. The paths are correct, but identity doesn’t use them. I noticed that this happens if I add template paths in settings before I enable identity. If I do it after, they are sent correctly. Is there a way to re-render these paths?

My app id: 53acada2-b60a-4778-b13d-b893aeed79cb

Hi @martinjagodic,

I checked our system and it looks like the email templates are set correctly and that the paths set exists in your published deploy. Is the site you mentioned still seeing the issue or did you already fix it?

Regarding adding the template before enabling Identity, being able to do so might be a bug but I don’t see that it is possible in the UI. But, have you tried changing the template path to something else and then back again after enabling Identity and see if that works to correct the issue?

Hi @Dennis, thanks a lot.

I checked again and thankfully the issue is gone. I didn’t touch it since I posted the comment, so maybe all we need is a little patience. I tried changing paths while debugging, but it didn’t have an (immediate) effect.

You are right, editing this is not possible without the Identity widget enabled.

Hi I’ve read through the above ^^ and https://docs.netlify.com/visitor-access/identity/identity-generated-emails/#email-templates and still, we are receiving the default template for registration confirmation, not the custom template we’ve added to the site and configured on Netlify Identity.

Our custom templates are located in a folder /email/
A leading “/” is included in the Netlify Identity configuration
The templates in the master branch of source are the same name as configured in Netlify Identity.

I’ve left it alone for a few days to make sure it wasn’t just a caching issue of some sort. I’ve renamed the directory and re-deployed to no avail.

What are we missing to get our custom email templates served?

@mgodeck, welcome to the Netlify Forums.

Can you tell me which site you have this configured on? You’ll want to make sure that the folder is included in your deploy. Can you check if that’s the case?

I see, yes it’s obvious now that the email template files are not being bundled into the release, /dist in this case. This is a (static) Nuxt build. If it were Hugo, I could put them under /static but that doesn’t appear to do the trick in Nuxt (2.x). So I think the answer to our question is one of Nuxt rather than Netlify. Looking…

It’s working now. For the record: it was correct to move the email templates folder to the /static directory in the Nuxt (2.x) directory structure; this results in the email directory being generated at the site root.

Thus, with the templates in /static/email/ the correct Netlify configuration path is simply /email/<template-name.html>.

1 Like

Hi. I have the same issue as many hear, but have done all the correct things described here.

Template file is available here: https://cisco-project-workplace-auth.netlify.app/templates/confirmation.html

Also verified by downloading built source, that the path is correct.

The path to the template file is correct:

The custom title is shown, but not the template body. I have redeployed the project and deleted cache. But confirmation emails still doesn’t show my template.

Any help? :pray:t2:

Hi there, @eivindml :wave:

Thanks for reaching out, and welcome to the Netlify Forums :netliconfetti:

Are you still experiencing this issue? If so, can you share the site name of the Netlify site where you are trying to use this? Additionally, can you share the repo if it is public? Thank you.