I get a Blank Page when I click on deployed url even thought it works on localhost


I have just joined Netlify and I got an error. I have uploaded my SVG Editor GitHub repo to the site and when I clicked on the netlify app link it displays a blank page even though when I ran on my localhost it works. I did loads of things and nothing seems to work. I even created a _redirects file in /src/editor with the text /* /src/editor/:splat 200 and did the same thing in netlify.toml under [[redirects]] but still doesn’t work. Can you please help me with this issue? Thank you.

Build Settings Details:

Hi @Angad-P,

Thanks for reaching out!

I see when visiting https://illustrious-tapioca-8a79d9.netlify.app/, Page Not Found is displayed. It doesn’t appear you have a redirects in your deploy. Could you try adding a _redirect or netlify.toml with the following redirect:

To do this, please add the “single page app” rule in our documentation here:

/* /index.html 200

You can find out more about how to create redirects here:

Let us know if you have any questions.

Also: You might want to get rid of that npm install command, Netlify automatically does that for you whenever there are changes in your package.json. Running it every time will drain your build minutes.

I already edited the _redirects file and netlify.toml several times. I even moved the _redirects file to public in the root directory but it now says “Page Not Found”. When _redirects is in src/editor the page is blank.

@Angad-P If you’re defining redirects using the _redirects file, you should ensure the file ends up in the output folder that is produced by your build process. Where you also have that output folder set as your Publish directory.

If you would like someone to check how you have your project itself configured, please make your repository public. The link that you have in your original post is currently private.