I can build and deploy my website with CLI, but not w/ Netlify: fixed it, error in netlify.toml

My site is teglaloroupepeacefoundation.netlify.app

My domain URL is http://teglapeace.org

I tried rebuilding the site with Netlify, but even though it said it built and deployed, it didn’t change the website.

So I tried CLI. I can build with Netlify CLI today, see the site locally with netlify dev, and deploy it to my domain URL with “netlify deploy --prod”. So CLI seems to have fixed a deploy problem with regular Netlify.

Now regular Netlify seems to have a problem.

The Netlify build and deploy now gives this error:

Error loading the CMS configuration
Config Errors:
Error: Failed to load config.yml (404)
Check your config.yml file.

Changing browsers gets the same result. Going to the URL, https://teglapeace.org, it seems to add a /#/ to the end, resulting in the above message.
If I go to a subdirectory, eg, Current Plans | Tegla Loroupe Peace Foundation, I get “Page Not Found”;

The reason I tried the CLI was because my successful Netlify builds somehow did not change the deployed web site. My site was not being published. The last time it was published was August, 2022; none of my builds today seemed to change this, even though the build and deploy seemed to work.

Found error. I cloned my year-old Netlify site to my local machine, to update Hugo.

  • I updated Hugo, but the Netlify deploy didn’t work. It said it did, but it didn’t.
    When I updated netlify.toml to the version that matched the version running on my local machine, it started working.

My netlify.toml file has the correct new Hugo version: v0.111.3.

Now to tackle DeCap CMS .

I’ve tried to install your repo but there isn’t a package.json. Can you please push this?

@kylesloper Thank you very much for examining this. I just pushed a package.json to Github. I hope this is useful.

I think I found the error. My netlify.toml had the wrong version of Hugo. When I changed it to the newest version: HUGO_VERSION = “0.111.3”, the deploy started working.

The sequence might be worth noting. My Netlify site hadn’t been touched for a year. To update Hugo, I cloned the site to my local machine, then updated Hugo, then found many build errors that I had to fix by creating new templates in the layout directory. I found them at the Hugo github sites, and just copied them.

After repeatedly building, I finally fixed all the build errors. So Netlify CLI worked, but Netlify didn’t, till I found the Hugo version mismatch: the old, cloned version was out of date in netlify.toml . So those refreshing their Netlify site should be warned to check the netlify.toml file.

Thank you for looking at this.