Hugo theme not applying, works locally

Hi guys,

New to Netlify and trying to deploy a Hugo site hosted on Github. The site works locally fine, but when I deploy to Netlify it’s like no CSS applies. I fixed some issues I noticed in the source html where CSS files would not resolve, I can now resolve them so not sure what is wrong.

I have tried using the default netlify.toml from the Netlify quickstart guide, I also tried using the themes netlify.toml as well but neither seem to change anything. Build completes successfully, no errors.

Netlify site:
Github repo: GitHub - donsfooty/
Hugo theme: ezhil

Thanks in advance.

I should add, I used this command to get the theme:
Git submodule add themes/ezhil

Found the issue, just for anyone else wondering:
1st line in config.toml, I had set the baseURL string to http:// instead of https://
Site now loads correctly on Netlify.

1 Like

Hi, @donsfooty, thank you for the follow-up to share the solution. This makes the community much more useful for people searching and our support team appreciates you taking the time to post the answer. :+1:

I had the same problem. But @donsfooty 's suggestion worked.


Thanks, this worked for me. One thing I also had to do was delete the existing index that was already there due to the clone. git rm -r --cached themes/learn/