HTTP Error 405 on form submission

Hello,
When I, or anyone, tries to submit a message through my form, it sends the user to an error page and the submission is not sent.

Netlify site name: https://agonzales.netlify.app
Custom domain (working): https://www.agonzales.dev/
Github repo: GitHub - gibstock/agonzales

It is a simple form with a simple setup. It was working as of May 20th (Last submission)

My last commit was 19 days ago, so nothing on my end should have changed.

Here is the code for the simple form:
troubleshoot-form-code

Here is the error page:
I guess new users can only embed one image in a post…
It is a standard error page (on chrome) with the text:

This page isn’t working
If the problem continues, contact the site owner.
HTTP ERROR 405

I have tried to add a custom success page through the action attribute and got the same issue.

I’m not sure what other actions to take to fix the form submission issue.

Thank you

Well, I’m not sure what changed. I submitted another test submission and it went through.

When I was testing it out, I sent the test submission from my local development environment. I used “test”
test@test.com
and for the body of the text “test”

I read that could lead to spam filters.

I then tried to submit using my real email and a real name and a real message, to no avail.

I just now tested it on my live site with real submission details and it worked. I happy it did, but I wish it didn’t so I could figure out why it wasn’t working.

Do submissions not get sent when from the local development environment?

hi there, what is your local environment like? How are you handling form submissions locally? if you are doing a simple local build but don’t have anything present to actually handle the form, then it wouldn’t surprise me that it doesn’t work.

once it is live on our servers, the netlify form handling takes over.

Hi Perry, you were correct that it wasn’t working on my local environment but it does work through my deployed website.

For completeness, I’m working in vs code with the live-server plugin for development. Initially, I got a report from a user that they were unable to send me a message through the form on the live website, which sparked my test in the local environment. I’m not sure why her message did not go through. My best guess is user input error.

Thank you for the help

1 Like