How to Properly set up DNS records for a locally hosted server on port 25565

Site Name: confident-wozniak-2ccf61

I am trying to set up a custom subdomain for confident-wozniak-2ccf61.
I have an externally registered domain called michielbugher.com
I am trying to set up minecraft.michielbugher.com on port 25565.

The first thing I did was add an A record as follows:
Name: minecraft.michielbugher.com
TTL: 3600 seconds
Type: A
Value: MyPublicIP (found on https://www.whatismyip.com/what-is-my-public-ip-address/)

At this point, I can successfully ping minecraft.michielbugher.com

Then I tried adding an SRV record to map the port to the subdomain that looks like this:
Service: minecraft
Protocol: tcp
Name: minecraft.michielbugher.com
TTL: 3600 seconds
Type: SRV
Priority: 0
Weight: 5
Port: 25565
Target: minecraft.michielbugher.com

After setting this and waiting for it to propagate, I still cannot connect on port 25565. I have verified that the port is forwarded properly using this site: yougetsignal.com/tools/open-ports/
The port is reported as opened when I use my public IP address, but is reported as closed when I put in minecraft.michielbugher.com.

Any help getting this properly set up is greatly appreciated.

-Michiel

hi, am i understanding correctly that you are trying to run a server on netlify? :thinking:

that’s not going to be possible -

Here is a good summary of what you can and can not do on Netlify you might find helpful:

No, I am definitely not trying to run a server on Netlify.

The scenario is that I have a publicly available server on my home network. The port is forwarded and I can get to it using my public IP address. I am just trying to use the Netlify DNS to route the traffic to the server on my network. This is necessary since I had to change my DNS to the Netlify one, so I can’t make these changes inside of Google Domains.

Hey @MichielDean! :wave:t2:

You’ve got a few options, but unless you have a static IP address from your ISP, you’ll probably want to setup a dynamic DNS interface so that your network will be resolvable when your ISP changes your IP address!

Beyond that (and you can skip that step temporarily to make sure things work, but things will subsequently break once your ISP changes your IP), having an A record for the correct subdomain resolving to your network public IP + port forwarding on your router from the correct external port to the correct port on your server / computer + making sure your local server doesn’t have firewalls / other policies blocking internal communications to the server process running on your machine… you should be good to go!


Jon

1 Like

good thing we have jon here to drop the knowledge!

Adding the A record definitely let me go to my public IP address, but the problem I’m having us with the SRV record, I think. I do not want to have to specify the port when I’m connecting to the server. Is there anything that you can see that is wrong with the configuration I’ve provided?

I have already fixed issues with port forwarding and firewalls, but I can’t get the DNS record to point at the IP + port.

When I check local IP + port, the site I provided says the port is open, but when I try from the URL, it says the port is closed.

I guess this is just a misunderstanding from me. I was trying to test connecting to the URL from my internal network, but it is not possible to do so. I had a friend try connecting to it and it worked just fine.