How to disable "Thank you" popup after submitting to form

Hello, I have a site with a form. It is all pure css, js and html. When someone submits, a pop up saying “thank you” pops up. How do I disable this? I already disabled form detection because I don’t want to receive the submissions, but the popup is still very annoying for users


Hi @Iviwe, welcome.

Visited the link you shared and then tested it by submitting the form more than once. No “thank you” pop up shows.

Once you don’t add the Netlify form attributes to the form it should work as expected.

Kindly check again to see if it works as expected or not.

Let me know the outcome.


1 Like

Sorry about that. I figured out how to fix the issue a couple hours after posting this question. I just added “action = ‘.’ “ to the html form tag. This made it so the form just redirected back to the same page after submitting instead of showing the “thank you” message, then giving the option to return to the site. That’s why it was fine when you tested it.

Still appreciate your help!

1 Like

Hi @Iviwe :wave:t6: welcome back to the forums! Thank you for coming back and providing that feedback on what helped solve your problem. Thanks so much! :hugs:

1 Like