Help committing github changes to deploy

I need advice to debug deploy

Error processing Markdown file /opt/build/repo/src/pages/blog/post3/
11:07:54 PM: can not read a block mapping entry; a multiline key may not be an implicit key at line 3, column 5:

hey sukhi,

9:07:54 PM: error Error processing Markdown file /opt/build/repo/src/pages/blog/post3/
9:07:54 PM:       can not read a block mapping entry; a multiline key may not be an implicit key at line 3, column 5:
9:07:54 PM:     date: '2019-04-01'
9:07:54 PM:         ^
9:07:54 PM: not finished source and transform nodes - 0.162s

this is a straightup compiler error. Something about your code here in this place isn’t working. Does this work locally?

Hey Perry, I’ve been editing this file from GitHub because I get a webpack error running locally from the command line due to changing the favicon. I’ve wasted tens of hours trying to fix it for other pages so I just stopped and resolved to using github to text-edit. Can we still troubleshoot if from there?

I changed the date from the default starter date to 2020, and I even tried changing it back but it’s not working.

Hi Sukhi, sorry to hear this has been such a struggle. this sounds very frustrating, for sure.

So the issue with editing the files directly on github is that we have no way of knowing whether or not this is actually a netlify issue or not. By running things locally and ensuring that they work first before deploying, you have “control group” if you will.

I think your best bet is to delete the file (for now) and try and get it working, and then we can see about adding more files? will you try that and see how it goes?

I am not a webpack expert so i can’t help you with that part, but i strongly recommend you have a working webpack config so you can test locally before you push.

Hello :slight_smile: great advice! thanks for your recommendations. I deleted the files from github resulting in the following deploy: yayyyyy

I still have to fix the webpack error to build locally, but I’m working on it. I think I learned my lesson about taking shortcuts.

I readded the post3 files and got this deploy

I changed the date locally before adding and it uploaded fine. I changed the title of the post and got this

Hey Perry. I thought making changes locally and adding to github would work but it doesn’t. Unfortunately I am still getting the same error thrown from the date

Can you tell if it’s netlify or something else based on this fact, or do I still need to get rid of the webpack error? :expressionless:

Hey @sukhi,

I can see that you have managed to successfully build since posting however I’d like to confirm that you’ve gotten to the bottom of this?

As Perry rightly stated, it appears to be a syntax error. Though, I assume you’ve worked this out now!

Hey @Pie thanks for checking in with me. I get the same error as show in the deploy log sites/fybr/deploys/5ed6a72352c2ce00066bfaf2

any advice? I’m working around it but I haven’t resolved it.

Well, it’s still there – a very clear error message!

If you have other posts, see how they’re written. If this one appears the same, try removing it.