Home
Support Forums

Having HTTPS for the internal CNAME bind to Netlify URL

I create an internal cname(app.xxxx.ai) in our AWS route53 to redirect traffic to https://xxxx-app.netlify.app/.
https://xxxx-app.netlify.app/ is on https but the cname(app.xxxxx.ai) record is loading on http. This is not a new domain. That is a subdomain!

All I want is making the CNAME in our side to be “http://[app.xxxx.ai” to “httpS://app.xxxx.ai/)”

Hi, @engineering1. I believe there is a support ticket open about this as well. If so, the issue in this case was that two names were added to the site settings at Netlify - app.xxxx.ia and www.app.xxxx.ia. The SSL provisioning is then failing as only one domain name has the required CNAME record. The SSL certificate is set for the site and must therefore include all requested domain names.

Because the DNS isn’t working for one of the domain names added, the SSL provisioning is failing. The solution is either to remove the non-working domain name from the site settings at Netlify or to add the missing CNAME record for the non-working domain.

If there are other questions or concerns, please let us know.