Google cannot crawl image/js/css files

Hello!

It appears from google search console, that google it is not able to correctly read images/js/css files from one of my domains hosted on netlify.

The blog is managed by hugo and gitlab, the images are hosted locally on netlify.

How can i allow thw crawl ?

thanks in advance

Hi @garethjax,

It would be helpful if we know which website you’re actually talking about so we can focus on debugging that.

In general, this doesn’t normally happen and the crawling works just fine, so there’s something special that might be happening, thus we need to be sure we’re debugging the correct website.

THIS IS EMBARASSING :

the website name internally is “distracted-goodall-96e5d9” and it’s mapped as www.neabbiamo.it

it’s embarassing because i’ve tested it again and this morning there is just 1 error reported from the search console!

but yesterday there were several!

i am clueless!

I don’t think it’s a Seach Console specific issue, because the assets are indeed returning 404:

Would you check your deployed folder if the assets really exists at the path? You can download your deploy and confirm it.

I’m getting an error while trying to download the deploy :frowning:

I will get back to you on this download problem, I can see the same error on multiple websites. Till then, if you can fix those 404s without downloading the deploy, I think that should solve your primary issue.

1 Like

actually today it solved itself… i don’t know how many days it has been going, the blog looks fine.

I noticed the issue because i’ve made a change on the repository related to the schema.org and i wanted to check if the search console was parsing it correctly.

it’s really weird!

Let me know if i can be of help, the site is mostly a hugo testing project, so feel free to ask: netlify is an amazing platform and i’m eager to help.

If the website is working fine, there’s a chance that you might not be needing those assets anymore but there might be references to those assets in your HTML file. If that’s the case, the best thing to do would be to remove those references so you won’t get such errors anymore.

i’m fixing the last css error at the moment, but there was a moment when one of the images included in an article was not loaded and now it’s working!

image

Awesome. So, I assume it’s all fixed now?

Also, about the download error, are there any browser extensions that might be interfering? They usually tend to cause problems. I just disabled those and was able to download deploys. Does that work for your case?

you’re correct, it was ublock which for some reason was blocking the download.

i’ve downloaded the archive and everything seems fine.

I’ve also checked the crawl stats from google, it seems the issue started on the 3rd of april and it went on until tonight. Apparently the new deploy “unlocked” something for Google?

We can mark the thread as solved if you agree, but it’s puzzling! Let me know if you want me to do further tests!

Google Search Console (or any other search admin UI for that matter) can be tricky. There are some errors that randomly pop-up and get fixed by themselves. Sometimes it’s instant, sometimes it takes months. In short, you should do some manual checks when you see some error just to make sure there are no real errors. If you can’t see the errors yourself, I think you’re good to go.

Now that it’s all working, that’s a good sign. If you have any additional questions, let us know.

1 Like