Forms are not found in code

I am stumped over an issue with forms detection. I have a website that is NOT built on Netlify. It is an old WordPress site, prepared for Netlify forms and then statically exported because no honest provider would support such an old PHP and WP versioning. There are multiple forms (on all Accommodation subpages, Book now, and Contact page in 4 languages each).

  1. all forms have data-netlify="true" as an attribute
  2. all forms have unique name attributes
  3. form processing is enabled

Nothing indicates that forms are checked or recognized when I deploy the site (pushing to Github, then Netlify updates by itself and deploys the export folder). The forms still have the data-netlify attribute inside the form tag, indicating they are not preprocessed.

I had it working in an earlier state, then discovered plenty of form fields in the reports that are not required and removed them within WP. Sometime after this, they stopped working. I think the point was when I added name attributes (I didn’t test between). Names are required, though, because “form 1”, and “form 2” that was automatically added didn’t help distinguish where they came from.

I tried the following approaches:

  • disable forms and enable them
  • all forms have unique names
  • deploy via CLI
  • deploy via Github
  • disable and enable post processing

None of them worked. I read through the troubleshooting docs for forms and if I didn’t list one of the approaches named there I forgot to list it here.

Build Log

10:56:38 AM: build-image version: 6c82004ef0368b3a0232c6837cead23188bb347e (focal)
10:56:38 AM: buildbot version: 0dfbdb6e6e614fd26450cfc6bacb47c4c6fd9626
10:56:38 AM: Building without cache
10:56:38 AM: Starting to prepare the repo for build
10:56:38 AM: No cached dependencies found. Cloning fresh repo
10:56:38 AM: git clone --filter=blob:none
10:56:39 AM: Preparing Git Reference refs/heads/main
10:56:51 AM: Parsing package.json dependencies
10:56:52 AM: Starting to install dependencies
10:56:53 AM: v16.20.0 is already installed.
10:56:53 AM: Now using node v16.20.0 (npm v8.19.4)
10:56:53 AM: Enabling Node.js Corepack
10:56:53 AM: Started restoring cached build plugins
10:56:53 AM: Finished restoring cached build plugins
10:56:53 AM: Started restoring cached corepack dependencies
10:56:53 AM: Finished restoring cached corepack dependencies
10:56:53 AM: No npm workspaces detected
10:56:53 AM: Started restoring cached node modules
10:56:53 AM: Finished restoring cached node modules
10:56:53 AM: Installing npm packages using npm version 8.19.4
10:57:00 AM: npm WARN deprecated source-map-url@0.4.1: See GitHub - lydell/source-map-url: [DEPRECATED] Tools for working with sourceMappingURL comments.
10:57:00 AM: npm WARN deprecated urix@0.1.0: Please see GitHub - lydell/urix: [DEPRECATED] Makes Windows-style paths more unix and URI friendly.
10:57:01 AM: npm WARN deprecated resolve-url@0.2.1: GitHub - lydell/resolve-url: [DEPRECATED] Like Node.js’ `path.resolve`/`url.resolve` for the browser.
10:57:01 AM: npm WARN deprecated source-map-resolve@0.5.3: See GitHub - lydell/source-map-resolve: [DEPRECATED] Resolve the source map and/or sources for a generated file.
10:57:01 AM: npm WARN deprecated stringify-package@1.0.1: This module is not used anymore, and has been replaced by @npmcli/package-json
10:57:02 AM: npm WARN deprecated @npmcli/move-file@2.0.1: This functionality has been moved to @npmcli/fs
10:57:03 AM: npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See There’s Math.random(), and then there’s Math.random() · V8 for details.
10:57:04 AM: npm WARN deprecated request@2.88.2: request has been deprecated, see
10:57:05 AM: npm WARN deprecated har-validator@5.1.5: this library is no longer supported
10:57:09 AM: npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
10:57:10 AM: npm WARN deprecated core-js@2.6.12: core-js@<3.4 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
10:57:14 AM: added 2702 packages, and audited 2703 packages in 21s
10:57:14 AM: 240 packages are looking for funding
10:57:14 AM: run npm fund for details
10:57:14 AM: 16 vulnerabilities (1 low, 4 moderate, 11 high)
10:57:14 AM: To address issues that do not require attention, run:
10:57:14 AM: npm audit fix
10:57:14 AM: To address all issues (including breaking changes), run:
10:57:14 AM: npm audit fix --force
10:57:14 AM: Run npm audit for details.
10:57:14 AM: npm packages installed
10:57:15 AM: Started restoring cached go cache
10:57:15 AM: Finished restoring cached go cache
10:57:15 AM: Installing Go version 1.19.5 (requested 1.19.5)
10:57:19 AM: go version go1.19.5 linux/amd64
10:57:20 AM: Using PHP version 8.0
10:57:20 AM: Python version set to 3.8
10:57:20 AM: Attempting Ruby version 2.7.2, read from environment
10:57:21 AM: Using Ruby version 2.7.2
10:57:22 AM: Install dependencies script success
10:57:22 AM: No build steps found, continuing to publishing
10:57:22 AM: Starting to deploy site from ‘export’
10:57:22 AM: Calculating files to upload
10:57:22 AM: 0 new files to upload
10:57:22 AM: 0 new functions to upload
10:57:22 AM: Starting post processing
10:57:22 AM: Section completed: deploying
10:57:22 AM: Section completed: building
10:57:22 AM: Post processing - HTML
10:57:23 AM: Post processing - header rules
10:57:23 AM: Post processing - redirect rules
10:57:23 AM: Post processing done
10:57:23 AM: Section completed: postprocessing
10:57:24 AM: Site is live :sparkles:
10:57:27 AM: Uploading Cache of size 939.2MB
10:57:32 AM: Section completed: cleanup
10:57:32 AM: Finished processing build request in 54.585s

Site name: chorchang
Site ID: ac024495-be46-4f44-b899-d67a2d7e3438
Last Deploy:

What might be the issue here? This is not my first Netlify site and not the first with forms. They usually work pretty nicely, as expected.

I also did an HTML check, and of course, there are many errors, but none within the form tag, so I don’t know if that influences the form detection.

From a quick test deploying a page with only one of the forms in it, the issue is the action URL as is possibly doesn’t exist or does not resolve (this URL must resolve for the form to work) e.g.


After removing the action the form was recognised.


Thank you for your response. That page might not have been exported… I’ll check and get back in a bit.

Edit: Thank you :slight_smile: That was exactly the issue. Thanks for your keen eye!