Form detected in build log, not in UI

I just created a new website. I had the same code already running on another website, but I decided to start with a fresh repo and website. The form was working fine before, but now I’m having a weird error.

My build log shows this:

10:43:42 PM: Starting to deploy site from 'public'
10:43:43 PM: Creating deploy tree asynchronously
10:43:43 PM: Creating deploy upload records
10:43:44 PM: Starting post processing
10:43:45 PM: Post processing - HTML
10:43:45 PM: Processing form - Contact form
10:43:45 PM: Detected form fields:
10:43:45 PM:  - bot-field
10:43:45 PM:  - Name
10:43:45 PM:  - E-mail addres
10:43:45 PM:  - Message
10:43:45 PM: Post processing - header rules
10:43:45 PM: Post processing - redirect rules
10:43:46 PM: Post processing done
10:43:46 PM: Site is live ✨
10:43:47 PM: 0 new files to upload
10:43:47 PM: 0 new functions to upload
10:43:47 PM: Site deploy was successfully initiated

First build log: Netlify App

It indicates that the form is detected.

But the UI shows this:

API ID of website in question is: 5a44a0e5-166c-4567-ad91-6a878aef2504

It just appeared in the UI in one of the deploys from yesterday without changing anything related to forms. So yeah a temporary glitch probably.

I am having the same problem. The form is detected but I don’t get any of the submissions. I have tried everything I have found on this forum and still nothing.

How did it work for you? Mine doesn’t seem to be a glitch.

I have deleted it and tried again. Left it for a few days and still nothing.

please help.

Hey @MDias04,

Which site is this regarding?

Hi @hrishikesh thank you for replying.

It is my ‘martadias’ website.

My logs show that a form is detected. But nothing ever comes through.
Screenshot 2022-03-28 at 20.31.05

hi there, when you are testing, are you testing with obvious “test” data or real data? we have had occurrences of people not receiving form notifications because our spam detection weeds them out.

I have added real data and different locations and also different devices. There’s nothing in the spam submissions either

Hello @MDias04

Taking a quick look on your website it seems that you are handling the form submit event, even though you don’t need to.

If you are using plain JavaScript to build your website, without any framework, can you try to just follow the basic steps of setting up the form, as described above. Just adding the data-netlify="true" is enough.

Let me know how that works out!

1 Like

Hey, @gualter thank you for your reply.

I have removed the js script completely to understand what was causing it and voila… I got mail.

It seems that having the submission button in JS conflicts with the rest. I will try to work around this. Because that button calls the thank you element from CSS.

But anyway, thank you so much for this I finally got the why isn’t it working. :raised_hands:

1 Like

Glad to hear that @MDias04!

If you need anything else let us know.