Form not working / not recognized in Svelte app

My Netlify site is:

I’m building in Svelte, not SvelteKit. I’ve tried using the data-netlify=“true” attribute, in addition to just using the netlify attribute. They aren’t recognized by Netlify, and I’m pretty sure it’s because I’m using Svelte. Something in the build process must not be working correctly.

I’m not using SvelteKit or Sapper, mostly because this is just a single page site, and I don’t need routing. I’m not sure what’s happening in the build process that prevents Netlify from recognizing my form, and I hope that someone else has run into this and knows the solution.

Thanks in advance,

Hey there, @nate-owens :wave:

Welcome to the Netlify Forums! Thanks for reaching out.

Hiya, sorry you are having trouble getting your forms to work.

This Support Guide is the first port of call to debug any forms issues. Please start here and work through these resources!

We also recommend trying to search the forums or look at topics related to forms and Svelte, you can view them here! While you may have a particular case, it is likely that these posts can get you pointed in the right direction.

If you are still having problems, please provide more information such as what you have already tried, your form name as it exists in the UI, your project repo, etc. :slight_smile: