First time Edge user, unable to use after a few tries

Trying Edge functions for the first time and following the guide, I created a new function using the code from the docs, ran ntl dev, and confirmed it worked correctly when I hit /test. Cool. I then modified the code to explicitly add the parameters:

export default async (request, context) => {
	return new Response("Hello world");

export const config = { path: "/test" };

Hit /test again, worked perfectly. Cool. So then I added console.log(request.headers), and… somethjing went really wrong. I got a lot of Deno errors in my terminal, lost now unfortunately, and nothing would work anymore.

I noticed a lot of processes marked defunct and was able to kill them. I got ntl dev running again, but my edge function no longer responds on /test, despite seeing “Loaded edge function”.

If I kill ntl dev, I notice: fork: retry: Resource temporarily unavailable being printed in my shell a few times.

A reboot fixed it, and after that I was able to edit/mod/play/etc, but just curious if this is something that just happens.

Hard to say without knowing what had happened, but this has not happened to me so far.