File really stuck in Netlify CDN

While deleting content from my site and adding _redirects to cover the same path, I ran into a weird issue where a particular file got “stuck” in the Netflix CDN and wouldn’t get invalidated/dislodged no matter what I tried.

I went so far as to delete my entire site and domain from my Netlify account, but this particular link is still stuck on the same file.

Also of interest – this file will ONLY be served if the request is made with an Accept-Encoding header that allows compressed objects.

Accept-Encoding: deflate, gzip

I’m really hoping support can help, otherwise I can’t think of any recourse other than pointing my DNS to a different provider. :frowning:

Hi Nic,

I think we talked through this privately - while none of the below were likely Nic’s problem, for anyone who comes across a similar situation, here’s what you should do to troubleshoot/debug:

  1. First, check to make sure you’ve actually built + deployed what you expect by downloading a copy of the deploy as demonstrated in this article: [Common Issue] I’ve deployed my site but I still see "Page not found” . This is our #1 cause of “stale content” is in the site BUILDING not serving, so you’d debug and solve that differently than stale content on the CDN.
  2. check your service worker configuration - they are often implicated in situations like this: . If you see the right content in a fresh browser but then subsequent loads don’t show updates, this is likely the cause.
  3. check your Split Testing settings ( as a forgotten split test may have some stale branch enabled that you are seeing…
  4. Once you’ve verified those, try a new deploy, as those clear our CDN’s cache of your site, during normal operation.
  5. Assuming you still see the bad content, send us the value of the X-NF-Request-ID HTTP response header FOR AN ASSET THAT IS NOT WHAT YOU EXPECT and send it to us. We can use that to analyze our internal logs.