"Failed to compile." message after 40 minutes of idle deploy

Hey! I’m trying to upload my react app. The app also has an express.js server.

I’m very new to full-stack and probably did something wrong in the process.

This is my scripts section in the package.json:

“scripts”: {
“start”: “react-scripts start”,
“build”: “react-scripts build”,
“test”: “react-scripts test”,
“eject”: “react-scripts eject”,
“dev”: “nodemon server”

I currently use npm start for react and npm run dev for the server.

In the deploy setting Build command I wrote: “npm run build && npm start”.

This is the log: Deploy details | omerinstagram (netlify.com)

I know that it may be an easy solution, I’m just really new at this and would love to understand what I did wrong :slight_smile:

Hi there, glad you found us :wave:t6: before we can help you, we need a little more information on the issues you are facing.

First, have you looked through this resource? It is a compilation of all of our build and deploy resources. This is a good starting point.

If you have worked through those guides and are still encountering issues please share the following information:

  • the name of your build instance: “example-jones.netlify.com
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console

You only use npm run build with Netlify.