Home
Support Forums

Drag and drop deploy fails with "A requested file or directory could not be found..."

I have dragged and dropped 2 static HTML sites into the Sites screen of the Netlify dashboard and they’ve deployed great.

When I drag and drop the 3rd static HTML site the drop target immediately changes to say

A requested file or directory could not be found at the time an operation was processed.

image

There is no error in the browser console and no further details.

I’ve looked through the files for this site; I can’t see anything different to the other 2 sites.

I tried uploading one of the ones that worked before as a new site and it worked, so it’s not a transient error @ Netlify.

Help please?!?

Update: If I zip up the directory, I can upload the zipfile and deploy. But if I drag the directory onto the uploader, it still fails.

Hey Peter and sorry to hear about the trouble!

Here’s the best practices for drag and drop deploys on our system (TL;DR, try not to do it; it’s the worst and least reliable way to deploy and we will not be able to fix the root causes of that):