DNS propagation taking 3+ days

I have been " Waiting on DNS propagation" on my site for over 3 days now.

My Netlify site is: https://gentle-genie-3d49bd.netlify.app/

The domain that I own is: https://www.pigeonracers.com/

I deployed 3 days ago, and although the website started working immediately, the DNS propagation is taking forever.

Please help.

Hi @siddhesvark :wave:t6: , welcome to the forums and thanks so much for reaching out. Propagation is taking so long because you didn’t configure your DNS properly so there is nothing to propagate. Can you take another look at this support guide and update the DNS records accordingly.

Hi Netlify,

This is what my current DNS setup looks like. Can you help me identify what I am doing incorrectly?

Sid K.

In addition to the resources offered by Sam @siddhesvark, I might point you to Configure external DNS for a custom domain | Netlify Docs

These are the records I see for the apex domain

% dig pigeonracers.com
pigeonracers.com.	600	IN	A
pigeonracers.com.	600	IN	A
pigeonracers.com.	600	IN	A

The first record is the Netlify load balancer IP. The other two records should not exist (as per documentation above.) Remove them and everything should sort itself out fairly quickly.


Is there another way to fix this?
GoDaddy won’t let me delete the other 2 Apex domains.

You need those records removed. If you cannot do it (clearly the screenshot shows you cannot) I suggest contacting GoDaddy as to why not. Possibly you are using a GoDaddy site/service that requires those records to work.

I don’t use GoDaddy so cannot offer specific help, but also check out Manage DNS records from GoDaddy’s Help Center.

Alternatively you could change your nameservers to use Netlify DNS instead. Check out

1 Like

Hi @siddhesvark once you reach out GoDaddy please let us know or if you change your nameservers.

Thanks for the support!

I have worked with GoDaddy to remove the 2 A records.
However, I am still not able to visit the https page securely.
I am also getting a " We could not provision a Let’s Encrypt certificate for your custom domain." error on my domain management settings page.
Do you know what the reason for this might be now?

Awesome. Everything works now!
Thanks again for the support!

Awesome! I’m glad you got this sorted. If you have any other problems please reach out. (: