DNS problem: Site not found & dig command produces a SERVFAIL error

I’m very much a beginner when it comes to dealing with DNS settings, but I have manged to set up a handful of sites, with one exception.
The domain name with the problem is griz.dev and I have it (and all my domain names) registered through Hover.

I have been comparing all of my settings for griz.dev to another domain of mine that works fine, grizfans.com. Both domains have been configured at Hover to use the same 4 name servers:

Screen Shot 2020-04-18 at 8.36.24 AM

From what I can see on my Netlify DNS page, these two domains are configured the same. Yet, grizfans.dev works, and griz.dev fails.

I did notice that when running the following dig command, I get an error for griz.dev:

; <<>> DiG 9.10.6 <<>> griz.dev @
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 63479
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;griz.dev.			IN	A

;; Query time: 37 msec
;; WHEN: Sat Apr 18 08:14:59 MDT 2020
;; MSG SIZE  rcvd: 37

Unfortunately, I’m just not knowledgeable enough in this area to get much further.
Any help would be greatly appreciated.


You might want to double-check your DNS entries. grizfans shows hover as the DNS server, not Netlify as you indicate.

I’ve never seen the dig response you’re getting with griz.dev, but if grizfans is not configured the way you think it is, griz.dev probably isn’t either.

If you don’t mind me asking, how were you able to determine this? Here’s what I see from within my Netlify account:

and since I’m a new user, I will have to post the 2nd screenshot in a new post below

Here’s my DNS setting configuration for griz.dev:

Those are indeed your settings within Netlify, but your domain registrar seems not to be pointing to Netlify for DNS resolution.

You can check A records, name servers, mail servers, CNAMEs, and more using this free online tool:


I may be doing this wrong, but I’m seeing something different using the GSuite Toolbox dig command. When I run that on grizfans.dev, I’m seeing NS results that match the Netlify name servers:

But, I get an error when checking the NS records for griz.dev

I see the problem - this was my mistake. I accidentally posted the wrong URL in my first post, I own both. Please disregard the .com version, it is the grizfans.dev domain that I meant to compare. I’m sorry for that mistake.

so, when comparing griz.dev vs grizfans.dev, the latter works, yet both seem to be configured the same in both Hover and Netlify’s DNS

Hi, @grizfan, this issue is happening because DNSSEC is enabled for this domain and Netlify DNS doesn’t support DNSSEC at this time:


The two solutions for this issue are:

  1. Disable DNSSEC for this domain (at the registrar).


  1. Stop using Netlify DNS and use our external DNS instructions instead.

If there are other questions about this, please let us know.

1 Like

Hi Luke,

Thank you so much for the suggestion! I did have DNSSEC on this domain, and not any other domains I use with Netlify. I’ve removed that, and will see how that works. But, I strongly suspect this will resolve the issue.

thanks again!

1 Like

confirmed solved, thanks again for the help!

Hi, @grizfan, thank you for the follow-up to confirm (which is super appreciated) and I’m glad to learn it is working now. Teamwork for the win! :+1: