DNS Problem: Site Not Found - DIG produces a SERVFAIL error

I deployed a build which is working on another netlify deployment, to a custom domain (marketplug.app)

The build deployed successfully, but when I go to http://marketplug.app - I get the following error:
“This site can’t be reached
marketplug.app’s server IP address could not be found.”

As per your documents - I looked the site up on Google’s Dig tool. I got the following message:
id 3930
opcode QUERY
flags QR RD RA
marketplug.app. IN NS

Based on this code - is there a problem with the configuration? I did this the exact same way I did another custom domain which took a few minutes to build.

It’s been nearly 2 hours.

Should I wait and see, or is there something fundamentally wrong based on the DIG message above?


@samm Who is your registrar? It looks as though you have no DNS entries, as there are no name servers or A records showing up.

If you haven’t made those entries, your site won’t show up until do have.

If you have made those entries, I would delete them and re-enter them, using as short a TTL as you can.

I’m using Google Domains. As I understand it, it’s simply a matter of pasting the Netlify nameservers i.e ‘dns1.p05.nsone.net’ into the UI on Google domains after going through the Netlify DNS setup process. This is what I did for a previous domain and it worked fine. Maybe I’m forgetting a step?

@gregraven I must have messed up the DNS setup process because I scrapped that build and deployed an entirely new build and it worked instantly.