DNS issue with CNAME record

Hey, I’m experiencing some issues which I believe could definitely be related to TTL with DNS but it’s been long enough that I want to make sure. The other day I added a CNAME record using Netlify DNS management to point to my Discourse forum community.temporal.io. Within minutes, visiting the site over my LTE internet yielded result, yet two days later I (in Sunnyvale) and coworkers (in Seattle) still fail to resolve the site. Instead we are greeted with the DigitalOcean “Not Found” page. Just to be clear, we’ve all cleared our OS-level DNS cache and I’ve completely reset my modem twice. After some dig-ing (I’m funny) it does indicate that a DigitalOcean server in SantaClara is serving the request, but it indeed returns the wrong records. The weird part is even online DNS checks show that the DNS is resolved to the correct CNAME, but in practice I can’t visit the site. Is there anything I can do to debug this or at least understand if I just need to wait?

Edit: Searching the forums indicates it might have to do with this NETLIFY DNS record for community.temporal.io which is un-removable in userspace.

Hiya @rylandg and sorry to hear about the trouble!

Seems like you have conflicting configurations for that hostname:

$ host community.temporal.io
community.temporal.io has address
community.temporal.io is an alias for temporal.hosted-by-discourse.com.
temporal.hosted-by-discourse.com has IPv6 address 2001:470:1:791::23
community.temporal.io is an alias for temporal.hosted-by-discourse.com.
temporal.hosted-by-discourse.com mail is handled by 10 mx-corp.discoursemail.com. 

You have both a NETLIFY (basically an “A” record), and a CNAME. If you meant to not have the netlify record, you can remove it in our UI, here:

First off, just want to say that I love Netlify and I really appreciate the support. Now here’s the weird thing, I swear to you that when I went to the DNS view yesterday and tried to remove the Netlify record it said “This is a system record that cannot be managed directly.”. But today when I went and double checked it now lets me delete that record. I could obviously be wrong but I would bet a lot that it didn’t let me do this yesterday. Not sure if there might be a bug lurking there, or something else but might be worth keeping an eye out for it :). Thanks again for the help, the issue is seemingly solved now.

Hi, @rylandg, we can unlock the NETLIFY/NETLIFYv6 records and there is more information about this here:

My best guess is that someone unlocked these for you. I’ve made sure all the NETLIFY/NETLIFYv6 records currently present for this domain can also be deleted (if you want to - you don’t have to).

If there are other questions or concerns, please let us know.