Deployment troubles - Blank page with a React app using React Router

I have a react site that completes the deploy process but it serves up an empty page. I believe it has something to do with not being able to find the index.html or it cant find the root…although, it loads the site title but nothing else. I’ve tried the redirects that are in the docs but nothing changes. I’m out of ideas on how to fix the problem. The app is on github and auto deploys.

github: GitHub - zacseewald/ZSP_site_2020


Check the source code of your webpage, you’ll find the answer. I’ll also add it here:

<!DOCTYPE html>
<html lang="en">
    <meta charset="utf-8" />
    <!-- <link rel="shortcut icon" href="%PUBLIC_URL%/favicon.ico" /> -->
    <link rel="shortcut icon" href="/favicon.ico" />
      content="width=device-width, initial-scale=1, shrink-to-fit=no"
    <meta name="theme-color" content="#000000" />
      manifest.json provides metadata used when your web app is installed on a
      user's mobile device or desktop. See
    <link rel="manifest" href="%PUBLIC_URL%/manifest.json" />
        <!-- Google Fonts -->
    <link href="|Montserrat|Overpass|Rubik|Rubik+Mono+One|Bebas+Neue|Comfortaa|Righteous&display=swap" rel="stylesheet">

      Notice the use of %PUBLIC_URL% in the tags above.
      It will be replaced with the URL of the `public` folder during the build.
      Only files inside the `public` folder can be referenced from the HTML.

      Unlike "/favicon.ico" or "favicon.ico", "%PUBLIC_URL%/favicon.ico" will
      work correctly both with client-side routing and a non-root public URL.
      Learn how to configure a non-root public URL by running `npm run build`.
    <noscript>You need to enable JavaScript to run this app.</noscript>
    <div id="root"></div>
      This HTML file is a template.
      If you open it directly in the browser, you will see an empty page.

      You can add webfonts, meta tags, or analytics to this file.
      The build step will place the bundled scripts into the <body> tag.

      To begin the development, run `npm start` or `yarn start`.
      To create a production bundle, use `npm run build` or `yarn build`.

I haven’t currently tested your repo, so I’m not sure if this is something you’ve done wrong or if it’s some problem with Netlify, but, this was just a quick look.

So, your index.html is there because if it didn’t exist, you’d have got a 404 error and not a blank page. There’s something else that’s wrong with your build.

Thanks so much! I’ll read through this