Home
Support Forums

Deployment Not Found (404) Deploy works on netlify but not custom domain

I deployed my react tailwind css site to netlify, however, when I added my custom domain it seems my netlify site is not working. I can still deploy my site and it works on the netlify server (https://60d4c6c97c956b0007a21201--flamboyant-archimedes-f9b5ac.netlify.app/) but it doesn’t work on my custom domain (onekyc.io). Whenever I visit onekyc.io I get a 404 error with the line (404: NOT_FOUND
Code: DEPLOYMENT_NOT_FOUND as seen below). I’ve tried a redirect with netlify.toml but that did not work. I’ve also tried clearing cache but that didn’t work either. Any help would be much appreciated! I’ve also attached a link to a TXT uploader that shows my deployment.


'Deployment' | TextUploader.com

Hi @Jake2,

I ca see your website fine on Netlify as well as custom domain.

Moreover, the screenshot you sent doesn’t match any of the default pages that Netlify serves. So it is possible it might be some kind of local cache acting up on your device. Try changing device/network.