Home
Support Forums

Deploy / build hung at 'uploading' permanently

The build is not failing. It’s stuck at the ‘building’ stage, and has been for over 14 hours. The subsequent build is stuck at ‘new’, unable to begin until the broken one is resolved.

Previous builds and deploys were successful, and there was only a minor cosmetic change before the unsuccessful deploy.

It appears to be a bug on the server end. There is this line in the build log:

9:21:26 PM: mv: cannot stat '/opt/buildhome/.nvm/versions/node/10': No such file or directory
9:21:26 PM: Cached node version 10
9:21:26 PM: /usr/local/bin/run-build-functions.sh: line 561: [: : integer expression expected

Note the reference is to ‘node version 10’, but I specified v11.9.0 in the .nvmrc, as logged earlier in the build:

9:21:00 PM: Attempting node version 'v11.9.0' from .nvmrc
9:21:01 PM: v11.9.0 is already installed.
9:21:01 PM: Now using node v11.9.0 (npm v6.5.0)

Any ideas on how to kill that build and continue with the next one?

(If an admin can help, it’s this deploy focused-elion-17290b/deploys/5caf85816a59bd000857e78c)
(As to the time in the log being 9:21 PM and my saying ‘over 14 hours’, it’s 11:28 AM here now. I promise I can tell time! :blush:)

Thank you all so much!

It is still hung, 24+ hours later.

@rendall I believe the builds timeout after 15 mins. Just kick off your next build and it should start running. No way to delete the build, just ignore it.

If you think you have a bug in your build environment, use the clear cache option on the “trigger deploy” in the admin dashboard under deploys.
image

1 Like

Thanks. That was the first thing I tried, and that second deploy is also stuck, at ‘new’, waiting for the ‘building’ one to finish.

I did write an email to support. Apparently this has been an issue in the past: https://twitter.com/netlifystatus/status/1110885886802051072

Thanks, again.

2 Likes

Sorry for the trouble, Rendall! That stuck build was caused by a bad deploy of our build service, which we cleared up soon after - didn’t realize it had left builds hanging though or we would have hunted them down.

I’ve unstuck that one and the next one went through.

2 Likes

Awesome! No apologies necessary. Great work. Much appreciated.

2 Likes

@fool I’m having a similar problem that I think was caused by some experimentation in which I changed the NODE_ENV to ‘development’. It’s cause the Netlify to launch a Vue.js dev server with no way to kill the process. Can you advise?

@fool lol I waited 25 min before posting here because I read somewhere there was a 15min timeout on builds, but 2 minutes after I posted the build was auto-killed after 30 minutes. Sorry for the trouble!

No problem, @esilverman! Basically, your build must complete in 15 minutes, and the deploy will time out in 30 minutes in case it hangs for whatever reason. So please reach out to Support if its been longer than 30 minutes! :slightly_smiling_face:

1 Like

I’m experiencing the same issue.

This is the end of the log ouput.

6:35:05 PM: Prepping functions complete
6:35:05 PM: Caching artifacts
6:35:05 PM: Started saving node modules
6:35:05 PM: Finished saving node modules
6:35:05 PM: Started saving yarn cache
6:35:05 PM: Finished saving yarn cache
6:35:05 PM: Started saving pip cache
6:35:05 PM: Finished saving pip cache
6:35:05 PM: Started saving emacs cask dependencies
6:35:05 PM: Finished saving emacs cask dependencies
6:35:05 PM: Started saving maven dependencies
6:35:05 PM: Finished saving maven dependencies
6:35:05 PM: Started saving boot dependencies
6:35:05 PM: Finished saving boot dependencies
6:35:05 PM: Started saving go dependencies
6:35:05 PM: Finished saving go dependencies
6:35:05 PM: Build script success
6:35:05 PM: Starting to deploy site from ‘’
6:35:05 PM: Creating deploy tree
6:35:06 PM: 0 new files to upload
6:35:06 PM: 1 new functions to upload
6:35:25 PM: Finished processing build request in 39.023652355s

My netlify.toml file is this:

[build]
  command = "yarn build"
  functions = "functions"

This is an API, there are no static assets to be served.

I have noticed that yarn will sometimes hang the continuous build, while npm will go through.

That said, if the hanging deployment prevents later deployment, it’s a different issue and Netlify staff will have to delete the deploy. At least, that was so in my case.

@hbarcelos, if your build is still stuck, provide the deploy link and I can cancel out that deploy manually.

Yes, it is still in progress.

…and as Dennis asked @hbarcelos if you could link us to it in your response then we are most likely to be able to help, since we can’t otherwise find it to investigate :wink:

Sorry, here’s the link:

https://app.netlify.com/sites/hbarcelos-kleros/deploys/5d54b525326cb9000bcbe21e

Problem still persists, even after I switched to NPM.

Sorry to see the trouble! It’s not any of the usual failure modes and the internal logs don’t seem to have any more details, so I can’t tell what is going on there either.

So I’ll try to get some advice from our operations team to check on it for us when they’re back in the office on Monday.

Hi again and sorry to say we didn’t get this diagnosed well during our time with the operations team this week. What I can tell is it is definitely about the files themselves, not the build process, so my proposal instead is to ask if you could send perhaps via DM a zipfile of your built site (I cannot see your repo; our staff cannot in general, only our build network can). That way, I can see if I can figure out what is causing problems by some experiments deploying it myself (on my own site of course!)

Hello. 3 months after and I’m still facing the same issues.

I can send you the zip file with my repository, but I’m having a hard time finding how to send you a DM. :sweat_smile:

Sorry about that! I only just found out that not every newer forum user can send a DM, so I sent you one to which I think you’ll be able to reply.

I have the same issues with 2 of my builds I tried just now… What do I do? I tried killing and rebuilding - did not work. I have enabled build plugins and incremental gatsby builds.
^
@fool

9:14:33 PM: Started saving go dependencies

9:14:33 PM: Finished saving go dependencies

9:14:33 PM: Build script success

9:14:33 PM: Starting to deploy site from 'public'

9:14:33 PM: Creating deploy tree asynchronously

9:14:33 PM: Creating deploy upload records

9:14:35 PM: 54 new files to upload

9:14:35 PM: 5 new functions to upload

9:15:36 PM: Finished processing build request in 4m8.045737795s